Saturday, September 22, 2007

I/O device error when reading SD card in Flash Card Reader - Vista

Maybe this will help someone else:Brand new laptop (Sony Vaio CR series) with integrated flash card reader. Everything on the laptop works fines, but when I inserted a 250MB or 2G flash card into the card reader, I kept getting an "The request could not be performed because of an I/O device error." error message. Attempts to browse the card caused the system to hang or freeze. Once I did manage to read the 250MB card, but after that it would hang trying to read it.Fix:Went to Sony's update site & discovered a manual update for Texas Instruments® Integrated FlashMedia Controller. I d/l'd it & browsed to the C:\Update directory & ran the install. Worked like a charm. Plugged the card in & *poof* opens right up. Also see this Microsoft KB article: http://support.microsoft.com/kb/936825 Note: this was a manual update, so you have to run the install yourself - it's not an "automatic update".PS - If you buy a Sony laptop (or any other running Vista w/ TI SD Flash Card Reader) from Best Buy, chances are they won't tell you about this update. I was about ready to take it back thinking it was a hardware problem when I decided to look for other patches/updates other than the usual Windows & virus updates. :-P This update apparently fixes a compatibility issue.

3 comments:

Anonymous said...

OMG! Thank you so much! This was the exact problem with my brand new sony laptop and i stumbled upon your blog and it is now fixed! yaay!

Gary said...

Gadget Girl,

Thanks so much, even though it took me forever how to get my right model number, finally got this working right thanks to your blog post. You are awesome and thanks for the post.

PammiePi said...

Glad to help! :-)